Back to overview
Downtime
Service Unavailable
May 24 at 03:53pm UTC
Affected services
Stacksync App
Resolved
May 24 at 04:47pm UTC
Service restablished
Affected services
Stacksync App
Created
May 24 at 03:53pm UTC
Downtime of our cloud provider
Affected services
Stacksync App